Error con Firefox 17 y editor WYSIWYG

28/11/2012       Javier Casas       Administración, OpenCms

Como suele ser habitual últimamente, la actualización de los navegadores están trayendo problemas con los editores WYSIWYG, en concreto, con el editor de contenido de OpenCms. A continuación mostramos los pasos a dar para solucionar el problema en nuestros OpenCms. 

  1. Editamos el fichero: /system/workplace/editors/fckeditor/editor_configuration.xml
  2. Añadimos la siguiente línea:

                 <agent>^Mozilla/5\.0 \(.*\) Gecko/\d+\.\d+ .*$</agent>

  1. Guardamos y publicamos el fichero
  2. Nos vamos a la vista de administración y reiniciamos el workplace

 

Nota: el fichero completo será:

<?xml version="1.0" encoding="ISO-8859-1"?>
<editor>
    <label>GUI_EDITOR_TITLE_FCKEDITOR_0</label>
    <widgeteditor>org.opencms.editors.fckeditor.CmsFCKEditorWidget</widgeteditor>
    <resourcetypes>
        <type>
            <name>xmlpage</name>
            <ranking>200</ranking>
        </type>
    </resourcetypes>
    <useragents>
        <agent>^Mozilla/[45]\.0 \(compatible; MSIE .*\)$</agent>
        <agent>^Mozilla/5\.0 \(.*\) Gecko/20\d* .*$</agent>        
        <agent>^Mozilla/5\.0 \(.*\) Gecko/\d+\.\d+ .*$</agent>
        <agent>^Mozilla/5\.0 \(.*\).*Chrome.*$</agent>
        <agent>^Mozilla/5\.0 \(.*\).* Version/[34].* Safari.*$</agent>
    </useragents>
</editor>