Problema con Firefox 4 y OpenCms 7.5.0 o anterior

Fri May 13 13:59:00 CEST 2011       Sergio Raposo Vargas       Administración, OpenCms

Quienes usen Firefox como navegador y trabajen con OpenCms habrán notado como tras actulizarse a la versión 4 de este popular navegador, los editores de contenido WYSIWYG (FckEditor) han dejado de funcionar.

Este error se debe a la configuración del editor en OpenCms, en concreto al fichero: /system/workplace/editors/fckeditor/editor_configuration.xml, en el cual se le dice los tipos de navegador con el que es compatible. Para solucionarlo debemos modificar dicho fichero para poner:

<?xml version="1.0" encoding="ISO-8859-1"?>
<editor>
	<label>GUI_EDITOR_TITLE_FCKEDITOR_0</label>
		<widgeteditor>org.opencms.editors.fckeditor.CmsFCKEditorWidget</widgeteditor>
		<resourcetypes>
			<type>
				<name>xmlpage</name>
				<ranking>200</ranking>
			</type>
		</resourcetypes>
	<useragents>
		<agent>^Mozilla/[45]\.0 \(compatible; MSIE .*\)$</agent>
		<agent>^Mozilla/5\.0 \(.*\) Gecko/20\d* .*$</agent>
		<agent>^Mozilla/5\.0 \(.*\).*Chrome.*$</agent>
		<agent>^Mozilla/5\.0 \(.*\).* Version/[34].* Safari.*$</agent>
	</useragents>
</editor>

Con esto se soluciona el problema, tan solo, una vez modificado debemos publicar el fichero y reiniciar el entorno de trabajo desde la administración.

Espero que os sea útil.

 Firefox4 OpenCms7.5 FckEditor Error